dotfiles/nixos-modules/base/boot.nix
Fabian Hauser e02d86dffd
All checks were successful
CI / build (push) Successful in 2m9s
Update and clean up modules
2025-03-03 23:46:19 +02:00

34 lines
712 B
Nix

{
inputs,
pkgs,
lib,
...
}:
{
imports = [ inputs.lanzaboote.nixosModules.lanzaboote ];
environment.systemPackages = [
pkgs.sbctl
];
boot = {
loader.timeout = 2;
tmp.useTmpfs = true;
kernelPackages = pkgs.linuxPackages_latest;
bootspec.enable = true;
loader.efi.canTouchEfiVariables = true;
initrd.systemd.enable = true;
# Lanzaboote currently replaces the systemd-boot module.
# This setting is usually set to true in configuration.nix
# generated at installation time. So we force it to false
# for now.
loader.systemd-boot.enable = lib.mkForce false;
lanzaboote = {
enable = true;
pkiBundle = "/var/lib/sbctl";
};
};
}