infrastructure/nixos-modules/system/applications.nix
2025-03-25 14:10:54 +02:00

53 lines
632 B
Nix

{
pkgs,
...
}:
{
environment.systemPackages =
with pkgs;
[
vim
tmux
killall
bc
rename
wipe
gnupg
ripgrep
]
++ [
nix-index
nix-diff
]
++ [
autojump
powerline-go
]
++ [
# File Utilities
ack
unzip
iotop
tree
vim
vimPlugins.pathogen
vimPlugins.airline
git
git-lfs
]
++ [
# Filesystem & Disk Utilities
parted
]
++ [
# Networking Utilities
nmap
bind
curl
wget
rsync
iftop
mailutils
];
}